Jeep Wrangler 4xe Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Installed my Grizzl-E Smart Charger (dip switches set to 32A) last night and set up the ChargeLab app with no issues. Plugged 4Xe in and estimated 2:14 hours to charge. Six hours later I wake up and look out the window and see the Grizzl-E box LED solid green and indicators on Jeep off. Opened up the ChargeLab app and says it's still charging, then opened the new Jeep app and shows fully charged.

Question: If I remove the phone app will the Grizzl-E still work and just use the Jeeps built-in Charging Schedule within the "Hybrid Electric Pages" in the 8.4 radio?
 

· Registered
2021 Jeep Wrangler Unlimited Sahara 4xe
Joined
·
32 Posts
Do yourself a favor and pack up the smart charger and return it for a “dumb” one. The Grizzl-e “dumb” charger is absolutely fantastic while the smart version is overwhelmingly buggy and has an app that never really works. Besides, why do you need a smart charger for a battery that takes 2.2 hours to charge? Use the scheduler in the Uconnect and it’ll work great.
 

· Registered
2022 Wrangler 4xe Rubicon
Joined
·
63 Posts
Do yourself a favor and pack up the smart charger and return it for a “dumb” one. The Grizzl-e “dumb” charger is absolutely fantastic while the smart version is overwhelmingly buggy and has an app that never really works. Besides, why do you need a smart charger for a battery that takes 2.2 hours to charge? Use the scheduler in the Uconnect and it’ll work great.
Agreed, I had so many issues with the smart charger causing the “Service Charging System” error message resulting in a trip to the dealer to get it cleared every time. Sent the charger back and got a dumb version, no issues since.
 
1 - 3 of 3 Posts
Top