Jeep Wrangler 4xe Forum banner
341 - 360 of 369 Posts

·
Registered
Joined
·
473 Posts
I have read a number of threads where the PIM had to be replaced. Seems like a common issue and the delay is probably caused by supply constraints.
 

·
Registered
2021 4Xe Rubicon on order...
Joined
·
1 Posts
Hello to the group. Just picked up a 4Xe Rubicon on Aug 21, on Aug 24th it started acting up with the lights on the dash, turtle light, EV modes not available, etc... Opened the fuse box and checked the fuses and relays. Found a bunch of relays and fuses that were not seated all the way in. Reseated the relays and fuses, took a 500 mile trip with no issues. Fingers crossed that's all it was.
 

·
Registered
Joined
·
6 Posts
Just picked up a new 4XE Rubicon last Saturday, before we could even make it home the check engine light was on. Ordered the Jeep in June and for the last three weeks ahead of shipping it was stuck in the extra quality inspection phase. When we took delivery we noticed the jeep had 45 miles and the center console was dented and scratched in the back by the batteries. On the way to and from the dealership we noticed that the jeep would not drive more than 15 miles in all electric before it threw an error saying Electric mode temporarily unavailable. Code read by the dealer and code was a faulty battery coolant pump. The pump was replaced and is still throwing the code. Second star case opened but no direction presently on what needs to be fixed. Brand new jeep that didn't even make it home before having problems is just sitting at the dealer now with no direction of what to do from the second star case open. It sounds like the jeep had issues at the factory and those issues wasn't fully addressed. Really really stinks
 

·
Registered
Joined
·
6 Posts
Update: The dealer just called and said that the new coolant pump was whining and that they had to add extra coolant to the battery and once they did that the pump stopped whining and the code went away. Really hopping that's all that was wrong. But it still doesn't explain the 45 miles and dent in the console coming from the factory after extended quality checks. Really would like to know what went on / got fixed ahead of it shipping as all the extended quality checks did not yield quality for us.
 

·
Registered
Joined
·
183 Posts
Just picked up a new 4XE Rubicon last Saturday, before we could even make it home the check engine light was on. Ordered the Jeep in June and for the last three weeks ahead of shipping it was stuck in the extra quality inspection phase. When we took delivery we noticed the jeep had 45 miles and the center console was dented and scratched in the back by the batteries. On the way to and from the dealership we noticed that the jeep would not drive more than 15 miles in all electric before it threw an error saying Electric mode temporarily unavailable. Code read by the dealer and code was a faulty battery coolant pump. The pump was replaced and is still throwing the code. Second star case opened but no direction presently on what needs to be fixed. Brand new jeep that didn't even make it home before having problems is just sitting at the dealer now with no direction of what to do from the second star case open. It sounds like the jeep had issues at the factory and those issues wasn't fully addressed. Really really stinks
Sorry to hear this so soon in ownership, 615ishome. If you need any extra assistance, please send us a private message.

Kate
Jeep Cares
 

·
Registered
Joined
·
1 Posts
Sounds like I'm going through the same issue. I purchased a 2021 4xe on 8/20. The salesman said they needed to replace a part due to a known issue, but they were working on it right then and I would be able to drive it out that day. Finished the paperwork and my sales guy said they are giving it a quick wash and I'll be ready to go. 45 mins later, the Parts Manager came out and said they need a part that is not in stock, but should be in the next day. They told me they would give me a loaner vehicle to drive since I traded in mine as part of the deal and they would contact me the next day to trade and deliver my 4xe to me. I was irritated, but agreed. No call the next day (Saturday). I called Monday to check on the status. The manager informed me that they needed a wiring harness and had to order from the dealership. The part would not be in until 9/1. I asked what I needed to do to cancel my purchase. They said they would take care of my first payment and I would continue to use the loaner vehicle until it's ready. Once again, I reluctantly agreed. Here we are on 9/2 and haven't heard anything from the dealership. I reached out to the sales rep today and asked for an update, but am waiting on a response.

Not sure how to proceed as I'm worried I have a lemon. I'm really leaning towards canceling my purchase. To top it off, I'm pretty sure they sold my trade in vehicle. Thoughts? Those that have had the wiring harness replaced, have you had any other issues pop up?
 

·
Registered
Joined
·
6 Posts
Positive update: Whatever fix was done at the factory (wondering if it was a wiring harness?) and the battery coolant pump along with added coolant fluids seems to have achieved some reliability? 700+ miles now on the first tank of gas with half of those fuel miles getting used when the hybrid system went down. In spite of all of that still may able to squeeze out 1000 miles on the first tank with a quarter tank of fuel left? Might could have achieved 1500 miles on the first tank without the problems. Not a good way to start out this journey but things are turning around. Wanted to post up both sides of the story in all fairness. Fingers crossed!
 

·
Registered
Joined
·
35 Posts
sweet, thanks for the reply.
I contacted N

Sweet thanks. I contacted the NCDS for a buyback arbitration. They have approved my request and are investigating at this time.
The dealer and Jeep care have both requested that the part I need be expedited. The vehicle supposedly needs a power inverter module, or PIM. FCA is not honoring the request to expedite the part. They have given an ETA of 1-2 weeks. Maybe longer.
Same problem I had in 2013 with my Ram with the 8.4 touchscreen failed due to a wiring issue caused no starts in a brand new truck that ended up going to lemon. Part was on back order however new trucks flying off the assembly line so obviously they had touchscreens for new builds just not repairs.
 

·
Registered
Joined
·
6 Posts
I haven't had a check engine light come on yet, but I did have one experience where the battery was depleted and the vehicle kept switching between the battery and gas every 15 seconds or so, then we suffered a terrible lurch that felt like the drivetrain dropped into 1st gear or something. Shut off the vehicle and turned it back on and haven't experienced anything like that since.
And you’re ok w tht?..what happens when this happens again just as your warranty is no longer valid ?
 

·
Registered
Joined
·
6 Posts
I’m on day three. I’m feeling like I’ll be counting down the days up to 30 in the next 900 or so...
Having the same thing…I think It has something to do w the rain or car washes….the charging station fault would come on and then I wasn’t able to charge it…it sometimes would clear itself but other times wouldn’t …I bought mine April 30 of this year…it’s currently getting a whole new brain( both wire harnesses) taking about a month to get them delivered to dealer then the work will need to be done…I’m not a happy camper at all…Chrysler has been calling the shots, driving around in a loaner,
 

·
Registered
Joined
·
6 Posts
So new today from the dealership is looking like replacing the complete wiring harness. Ship date May 22, so the first my wife will not get to enjoy her can till June I am guessing. Our brand new Jeep now gets to sit outside getting the shit beat out of it by the sun and no care being done to it. Total bullshit.
Right there w ya
 

·
Registered
Joined
·
36 Posts
I just got my car back from getting a part replaced and yes, I’m hearing water sloshing around under the back seat. I don’t know what that noise is but it wasn’t there before I brought it to the dealer for service.
Im having the same issue now after service. What was the diagnosis. I just had a harness and PIM module replaced.
Now check engine light is on and hear a water sloshing noise from back seat.
 

·
Registered
Joined
·
4 Posts
Positive update: Whatever fix was done at the factory (wondering if it was a wiring harness?) and the battery coolant pump along with added coolant fluids seems to have achieved some reliability? 700+ miles now on the first tank of gas with half of those fuel miles getting used when the hybrid system went down. In spite of all of that still may able to squeeze out 1000 miles on the first tank with a quarter tank of fuel left? Might could have achieved 1500 miles on the first tank without the problems. Not a good way to start out this journey but things are turning around. Wanted to post up both sides of the story in all fairness. Fingers crossed!
How many miles were you getting on Electric alone? My 4xe just popped up with all these issues/lights this morning.
 

·
Registered
Joined
·
1 Posts
New Jeep4xe owner, love the car but at 527 miles check engine light came on. Autozone code reader says it is a P04ee. I have checked fuel cap and fuses and all are fine. Any ideas?
 

·
Registered
Joined
·
473 Posts
This is from another thread of a similar topic

The errors were P04EE "EVAP System Very Small Leak Detected - Fuel Tank Side" and P04EC "EVAP System Large Leak Detected - Fuel Tank Side". I reseated the gas cap and cleared the codes and it hasn't come back.
 

·
Registered
Joined
·
6 Posts
How many miles were you getting on Electric alone? My 4xe just popped up with all these issues/lights this morning.
We are going strong after the fixes. We burned a half tank of gas while the hybrid system was down. Right now we are up to 850+ miles on the first tank of gas, with around 40 miles of gas still showing in the tank. Still might make it to 1000 miles on the first tank.
 
341 - 360 of 369 Posts
Top