Jeep Wrangler 4xe Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Have my car a week. Waiting to get Level 2 Charger but in the meantime using the provided Level 1. This charger is just not working, it will charge for 5 minutes or so then start flashing red and yellow lights. Watched Jeeps video and when they plug in the charger to the wall, they wait for all 3 lights to turn green. My charger doesn't do that, just the top light turns green. the other 2 stay blank. Can anyone tell me if all lights should turn green before charging? Heading to dealer tomorrow but this is all new to them and the really do not know anything about it. Thanks
 

·
Registered
Joined
·
18 Posts
Have my car a week. Waiting to get Level 2 Charger but in the meantime using the provided Level 1. This charger is just not working, it will charge for 5 minutes or so then start flashing red and yellow lights. Watched Jeeps video and when they plug in the charger to the wall, they wait for all 3 lights to turn green. My charger doesn't do that, just the top light turns green. the other 2 stay blank. Can anyone tell me if all lights should turn green before charging? Heading to dealer tomorrow but this is all new to them and the really do not know anything about it. Thanks
Only one green light on mine too, but it works.
 

·
Registered
Joined
·
2 Posts
Have my car a week. Waiting to get Level 2 Charger but in the meantime using the provided Level 1. This charger is just not working, it will charge for 5 minutes or so then start flashing red and yellow lights. Watched Jeeps video and when they plug in the charger to the wall, they wait for all 3 lights to turn green. My charger doesn't do that, just the top light turns green. the other 2 stay blank. Can anyone tell me if all lights should turn green before charging? Heading to dealer tomorrow but this is all new to them and the really do not know anything about it. Thanks
I have the same issue
 

·
Registered
Joined
·
3,069 Posts
every 15 mins all three lights on Level 1 charger lights up and charging stops.
do any of them flash or anything or just all three come on?

Generally when all 3 are illuminated, it's an issue with your outlet. Which ones are flashing point towards if it's a grounding problem or an overheating issue. It being after 15 minutes suggests an overheating issue.
 

·
Registered
Joined
·
8 Posts
do any of them flash or anything or just all three come on?

Generally when all 3 are illuminated, it's an issue with your outlet. Which ones are flashing point towards if it's a grounding problem or an overheating issue. It being after 15 minutes suggests an overheating issue.

Thanks for a prompt respose.
I get solid red and blinking yellow in 15 mins of plugging in. This was not there for first 10 days, i got the 4xe
 

·
Registered
Joined
·
3,069 Posts
Solid green, solid red, and constant flashing of the yellow is an overheating condition at the outlet. Your outlet likely has either a loose wire connection at the back of it or is losing spring tension so you're getting poor contact. Over 15 minutes or so it's heating up, and then throwing an error when it gets too hot.

 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top