Jeep Wrangler 4xe Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
806 Posts
Discussion Starter · #1 ·
Being a long time member here, it seems like most of the issues these days center around FORM and/or cold weather impacts. Based solely on my observation, it appears that we are seeing far fewer posts around the original pain points with the charging system error that caused engine to shut down or people's vehicles simply stopping on the highway. I know Jeep had a recall and a number of software updates that seem to have solved the issue for MOST. I understand some are still having this issue so I'm not suggesting it is eradicated but it does seem better.
 

·
Registered
Joined
·
17 Posts
@Sjbiss - I have only been a member for just about a month. It does appear that there are fewer issues dealing with FORM. And it also seems that many people are now understanding that the 4xE is a Hybrid not a pure EV. As a Hybrid it is designed to operate in that mode and regardless of using the "Electric" mode button because the system can still kick on the ICE for added power etc. One of your other statements (in another post) was also spot on - Jeep designed the 4xE to be a Jeep 1st. If people keep that in mind and stop thinking that the vehicle is made to run in Electric all the time then some of the criticisms for the vehicle will die down. Anyway.. just my 2 cents :cool:
 

·
Registered
Joined
·
329 Posts
My Jeep went into FORM for the first time a month ago. It definitely didn’t seem to run as smooth when the ICE kicked on every morning when I got to the highway. But once I ran the gas down and the low fuel light came on - it’s out of FORM and running normal. So fingers crossed and I’m loving driving this thing.
 
1 - 3 of 3 Posts
Top